SnapHOA - Management: Invoices Not Processing

Incident Report for Action Property Management

Resolved

The issue affecting recently uploaded invoices has been resolved. All invoices that were currently stuck in a “processing” status have been released.

If you encounter any issues and/or need additional support, please use the Contact Support link located at https://linktree.actionlife.com for further assistance.

As always, we thank you for your patience.
Posted Mar 12, 2026 - 13:22 PDT

Investigating

It has come to our attention that invoices uploaded in SnapHOA – Management are currently stuck in a “processing” status. Our team is actively investigating the issue. We will provide an update once we have one.

Thank you for your patience.
Posted Mar 12, 2026 - 13:00 PDT
This incident affected: SnapHOA (Management App).