HOA Inspection App Notice – Offline Amenity Inspections

Incident Report for Action Property Management

Resolved

The concern related to offline Amenity Inspections within the HOA Inspection Mobile App was previously resolved.

As always we thank you for your patience!
Posted Jun 05, 2026 - 08:31 PDT

Investigating

It was brought to our attention that there is currently an issue affecting offline Amenity Inspections within the HOA Inspection Mobile App.

Our Development team is actively investigating the issue and working toward a resolution.

At this time, if you are performing an Amenity Inspection using the HOA Inspection Mobile App, please ensure you have an active internet connection throughout the inspection process.

We are aware of the issue and will provide updates as soon as additional information becomes available.

Thank you for your understanding and patience while we work to resolve this matter.
Posted Jun 02, 2026 - 12:40 PDT
This incident affected: SnapHOA (Mobile App).