SnapHOA - Management: Notification Delivery Issue

Incident Report for Action Property Management

Resolved

The issue affecting the delivery of SnapHOA - Management email and text notifications has been resolved. Notification processing has returned to normal, and messages generated by SnapHOA - Management are now being delivered as expected.

We appreciate your patience while we worked to restore service and apologize for any inconvenience this disruption may have caused.
Posted May 29, 2026 - 19:21 PDT

Investigating

Our Support Team is aware of an issue affecting the delivery of SnapHOA - Management notifications and is actively investigating it.

At this time, all SnapHOA - Management generated email and text notifications are delayed and may not be delivered as expected.

We appreciate your patience and will provide updates as additional information becomes available.
Posted May 29, 2026 - 17:10 PDT
This incident affected: SnapHOA (Management App, Resident/Board Portal).