Historical Invoice Search Error & Bank Account Display Issues

Incident Report for Action Property Management

Resolved

The issues impacting historical invoice searches in the Legacy Invoice System and bank account visibility on invoices have been resolved.

Our team has confirmed that all affected functionality is operating normally. Team members should now be able to search historical invoices and view associated bank account information as expected.

Thank you for your patience while we investigated and resolved these issues.
Posted Jul 20, 2026 - 15:58 PDT

Investigating

It has come to our attention that Team Members are currently experiencing concerns when searching for historical invoices in the Legacy Invoice System. Additionally, invoice bank account information is not displaying on invoices and within the Invoice Bank Account Tab as expected.

We are aware of the issue and will provide updates as soon as additional information becomes available.

Thank you for your understanding and patience while we work to resolve this matter.
Posted Jul 20, 2026 - 15:36 PDT
This incident affected: SnapHOA (Management App).