SnapHOA – Intermittent Slowness in SnapHOA – Management

Incident Report for Action Property Management

Resolved

We’re happy to confirm that the issues related to the recent global Amazon Web Services (AWS) outage have now been resolved. If you encounter any further issues, please Contact Support and we will be more than happy to assist you.

As always, we thank you for your patience!
Posted Oct 21, 2025 - 11:09 PDT

Identified

We are currently experiencing intermittent slowness within SnapHOA – Management. This issue is related to a recent global Amazon Web Services (AWS) outage, which is still in the process of recovering. Team Members may experience delayed page loading, longer-than-usual PDF generation times, or issues saving/downloading certain attachments.

As AWS continues to restore affected services, performance may fluctuate. Once the issue is fully resolved, we will perform additional diagnostics to ensure that all SnapHOA systems are stable.

We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Oct 20, 2025 - 09:56 PDT
This incident affected: SnapHOA (Management App, Resident/Board Portal).