SnapHOA - Management Announcement Feature Issue

Incident Report for Action Property Management

Resolved

The issue affecting the SnapHOA - Management Announcement feature has been resolved. If you encounter any issues and/or need additional support, please Contact Support for further assistance.

As always, we thank you for your patience.
Posted Apr 03, 2026 - 09:45 PDT

Investigating

It has come to our attention that the SnapHOA - Management Announcement feature is currently not functioning as expected and displaying an error.

Our team is actively investigating the issue and working toward a resolution. We will provide an update as soon as more information becomes available.

Thank you for your patience and flexibility as we work to resolve this issue.
Posted Apr 03, 2026 - 08:47 PDT
This incident affected: SnapHOA (Management App).