VDI Certificate Error

Incident Report for Action Property Management

Resolved

The issue has been resolved. If affected you should be able to login now!
Posted Jun 04, 2026 - 18:00 PDT

Investigating

It has come to our attention that VDI users are experiencing an issue when attempting to make a new connection to the VDI server through their Horizon client. Specifically, they will receive an error that the certificate is invalid.

We are currently investigating the issue and working towards a resolution.

Please be on the lookout for future updates.

Thank you for your patience.
Posted Jun 04, 2026 - 16:55 PDT
This incident affected: VDI.