SnapHOA - Management: Packages Error

Incident Report for Action Property Management

Resolved

We’re happy to confirm that the issue has now been resolved. The Pick Up, Deliver, and Sign for Packages buttons are all functioning as expected. The package workflow should be able to be completed without interruption. If you encounter any further issues, please Contact Support and we will be more than happy to assist you.

As always, we thank you for your patience!
Posted Jul 01, 2025 - 15:21 PDT

Investigating

We are currently aware of an issue affecting the Packages feature within SnapHOA – Management. Specifically, the Pick Up/Deliver buttons as well as selecting the Sign for Package button, which is preventing packages from being able to be marked as no longer in the association's possession.

Our team is actively investigating the issue and working on a resolution. We’ll provide an update as soon as we have more information.

Thank you for your patience and understanding.
Posted Jul 01, 2025 - 14:42 PDT
This incident affected: SnapHOA (Management App).